System Requirements - Intershop Progressive Web App 4.1

Table of Contents


Product Version

4.1

Product To Version

4.1
Status

Operating System

Operating System (not included in the product)

Any operating system running Node.js

Web Server

Web Server (not included in the product)

Any web server running Node.js

Node.JS

Node.js (not included in the product)

Node.js version 18.x LTS

Node Package Manager

Node Package Manager (not included in the product)

npm version 9.x

Git

Git (not included in the product)

Any Git service (in order to consume the provided Git project)

For development with Husky Git hook support Git >= 2.13.0 is required

Intershop Commerce Management

Intershop Commerce Management (not included in the product)

Intershop Commerce Management 7.10.39.2 or higher

Browser

  • Mozilla Firefox 114 and later
  • Google Chrome 114 and later
  • Microsoft Edge 114 and later
  • Safari 16.4 and later

Note

JavaScript and cookies must be enabled to use the whole set of functionality.

Docker

Docker (not included in the product)
For building the Docker image supplied with the Dockerfile in the root folder of the project (e.g. for production)
Disclaimer

The information provided in the Knowledge Base may not be applicable to all systems and situations. Intershop Communications will not be liable to any party for any direct or indirect damages resulting from the use of the Customer Support section of the Intershop Corporate Web site, including, without limitation, any lost profits, business interruption, loss of programs or other data on your information handling system.

The Intershop Customer Support website uses only technically necessary cookies. We do not track visitors or have visitors tracked by 3rd parties.

Further information on privacy can be found in the Intershop Privacy Policy and Legal Notice.
Customer Support
Knowledge Base
Product Resources
Tickets