System Requirements - Intershop Progressive Web App 0.20

Product Version

0.20

Product To Version

0.20
Status

final


 

1 Operating System

Operating System (not included in the product)

Any operating system running Node.js

2 Web Server

Web Server (not included in the product)

Any web server running Node.js

3 Node.JS

Node.js (not included in the product)

Node.js version 12.13.0 LTS

4 Node Package Manager

Node Package Manager (not included in the product)

npm version 6.12.0

5 Git

Git (not included in the product)

Any Git service (in order to consume the provided Git project)

For development with Husky Git hook support Git >= 2.13.0 is required

6 Intershop Commerce Management

Intershop Commerce Management (not included in the product)

Intershop Commerce Management 7.10.18.1 or higher

7 Browser

  • Mozilla Firefox 76 and later
  • Google Chrome 83 and later
  • Microsoft Edge 83 and later

Note

JavaScript and cookies must be enabled to use the whole set of functionality.

8 Docker

Docker (not included in the product)
For building the docker image supplied with the Dockerfile  in the root folder of the project (e.g. for production).

Disclaimer

The information provided in the Knowledge Base may not be applicable to all systems and situations. Intershop Communications will not be liable to any party for any direct or indirect damages resulting from the use of the Customer Support section of the Intershop Corporate Web site, including, without limitation, any lost profits, business interruption, loss of programs or other data on your information handling system.

Customer Support
Knowledge Base
Product Resources
Support Tickets